RSS구독하기:SUBSCRIBE TO RSS FEED
즐겨찾기추가:ADD FAVORITE
글쓰기:POST
관리자:ADMINISTRATOR
분류없음  2016/12/06 11:44

## Switch port ##

 

 

 

-L2 port(switch port):(ip X)access/trunk/tunnel

 

-L3 port:(ip 0)routed port / SVI

 

모델마다차이가있으나 ip 입력을했을설정이먹히면 L3 sw L2기본적으로되어 L3 SW 설정을해줘야.

 

  • No switchport설정은 interface들어갈때마다해야함

 

SW1(config)#int f 0/1

 

SW1(config-if)#no switchport

 

SW1(config-if)#ip add 1.1.1.254 255.255.255.0

 

 

 

*Routing table 설정

 

SW1(config)#ip routing (sw routing 설정시입력해줘야함)

 

SW1(config)#router rip

 

SW1(config-router)#ver 2

 

SW1(config-router)#network 3.0.0.0

 

SW1(config-router)#network 1.0.0.0

 

SW1(config-router)#no autosummary

 

 

 

## L3 switch이용한 Inter-VLAN Routing##

 

  • Router -

 

  1. Major interface

 

  1. Sub-interface

 

 

 

  • L3 Switch -

 

  1. Routed port

 

  • L3 스위치에 ip 설정

 

interface FastEthernet0/21

 

 no switchport

 

 ip address 1.1.10.254 255.255.255.0

 

interface FastEthernet0/22

 

 no switchport

 

 ip address 1.1.20.254 255.255.255.0

 

interface FastEthernet0/23

 

 no switchport

 

 ip address 1.1.30.254 255.255.255.0

 

  • L3스위치와마주보는빽본스위치에서 VLAN 설정

 

BB(config)#int f 0/21

 

BB(config-if)#sw mo ac

 

BB(config-if)#sw ac vl 10

 

BB(config-if)#exit

 

BB(config)#int f 0/22

 

BB(config-if)#sw mo ac

 

BB(config-if)#sw ac vl 20

 

BB(config-if)#int f 0/23

 

BB(config-if)#sw mo ac

 

BB(config-if)#sw ac vl 30

 

  • L3 SW처음엔라우팅기능이없어 ping전달이안됨그래서 L3 SWSW1(config)#ip routing주지않으면 Routing Table보이지않음

 

 

 

## SVI(switch virtual Interface) ##

 

2) SVI

 

Router : loopback  /  switch : SVI(VLAN)으로생성함

 

-L2 Switch -> 관리용 (원격접근)

 

               -> 여러개의 SVI 생성하나만사용가능

 

 

 

-L3 switch -> 관리용 / Gateway / Routing

 

 -> 여러개의 SVI 생성모두사용가능

 

 

 

switch:SVI(VLAN)으로생성 ( VLAN 10 경우는 no shutdown 줘야함)

 

1F_SW(config)#interface vlan 10

 

1F_SW(config-if)#ip add 1.1.10.10 255.255.255.0

 

 

 

1F_SW(config-if)#line vty 0 4 (5명까지접속가능)

 

username admin password cisco 가능

 

1F_SW(config-line)#password cisco

 

1F_SW(config-line)#login

 

PC 에서 telnet 접근가능함 / PC에서 telnet접근이안될경우는게이트웨이가설정되지않아돌아오는길이핑이끊김(Routing Protocol 설정없으니설정이라생각하면)

 

1F_SW(config)#ip default-gateway 1.1.10.254

 

 

 

- L3 스위치에게 Routing 기능을 부여하는 명령어는 [ip routing]

 

  명령어이다.

 

 

 

*SVI 설정 (switch가상에 interface)

 

SW1(config-if)#no switchport / Routing되게변경

 

SW1(config)#int f 0/1

 

 

 

L3_SW(config-vlan)#vlan 10

 

L3_SW(config-vlan)#vlan 20

 

L3_SW(config-vlan)#vlan 30

 

L3Switch(config)#int f 0/10

 

L3Switch(config-if)#switchport trunk encapsulation dot1q

 

L3Switch(config-if)#switchport mode trunk

 

L3Switch(config-if)#switchport trunk allowed vlan 10,20,30

 

L3Switch(config-if)#switchport nonegotiate

 

L3Switch(config)#inter vlan 10

 

L3Switch(config-if)#ip add 1.1.10.254 255.255.255.0

 

L3Switch(config)#inter vlan 20

 

L3Switch(config-if)#ip add 1.1.20.254 255.255.255.0

 

L3Switch(config)#inter vlan 30

 

L3Switch(config-if)#ip add 1.1.30.254 255.255.255.0

 

L3Switch(config)#ip routing // Routing table볼려면해야함

 

BB(config)#int f 0/10

 

BB(config-if)#switchport mode trunk

 

BB(config-if)#switchport trunk allowed vlan 10,20,30

 

BB(config-if)#switchport nonegotiate

 

 

 

  • 내부단은라우터보다 L3 SW사용하는게효율적임

 

  • 말단은 access단으로설정함

 

  • SWSW 사이는 trunk 사용
  • 보안성으로유저와서버와같이붙여놓치않음
  • NAT(1:1=static, n:n=dynamic, 1:n=PAT)

 

 

 

 

 

서로 pc통신가능, L2 SW 모두 telnet 접속가능

 

지사끼리통신가능

 

본사내부 routing protocol

 

백본sw 모두 default으로넘겨줌

 

 

 

  • Access-list설정

 

 

 

##NAT##

 

A class 10.x.x.x/8

 

B class 172.16.x.x/16 ~ 172.31.x.x/16

 

C class 192.168.0.x/24 ~ 192.168.255.x/24 --> 192.168.0.0/16

 

  • 사설 ip기업내부에서사용하는통신하는 ip.

 

##NAT 설정##

 

*Dynamic NAT

 

Ip변환에서사용할전역주소설정

 

:ip nat pool bane start-ip end-ip netmask

 

 

 

 

 

 

 

내부에서 ip 변환을허용할주소를 standard Access-list정의한다

 

:access-list number permit source-address

 

동적변환을수립하기위한 NAT 설정

 

:in nat inside source list 10 access-list interface fa0/1 name (overload)

 

인터페이스로이동내부와외부를각각설정함

 

:ip nat inside / :ip nat outside

 







 

 

NAT:int f 0/1

 

NAT:ip add 100.123.65.1 255.255.255.0

 

NAT:no sh

 

NAT:int f 0/0

 

NAT:ip add 192.168.1.1 255.255.255.0

 

NAT:no sh

 

 

 

NAT:ip route 0.0.0.0 0.0.0.0(ip default-gateway) 100.123.65.2 isp 공인ip 공간

 

NAT:access-list 10 permit 192.168.1.0 0.0.0.255 // 사설ip 허용

 

 

 

10.10.0.0 0.0.255.255 

 

10.10.10.0 0.0.0.255

 

10.10.20.0 0.0.0.255

 

10.10.30.0 0.0.0.255 - 묶어서 10.10.0.0 ~0.0.255.255 입력가능

 

 

 

NAT:ip nat inside source list 10 int f 0/1 overload // nat f 0/1공인ip

 

NAT:int f 0/0

 

NAT: ip nat inside / 사설ip

 

NAT:int f 0/1

 

NAT: ip nat outside /공인ip

 

NAT:sh ip nat translations // nat설정확인

 

 

 

  • NAT ( 비용절감 ip 개수부족, 보안성)

 

1.static (1:1) -> 평소에도들어옴 / 외부에서내부로들어올때

 

 

 

2.dynamic (n:n) -> 그룹:그룹이기때문에평소에연결안됨외부에서내부로나가는순간에특정공인 ip하나씩물고외부로나감

 

 

 

3.PAT (1:n) -> 하나공인 ip사설 ip사용 / 공유기와비슷함

 

     하나의 port많은(이론상 64,000) 사설 ip 사용가능

 

     pool대신 int s 0/0사용가능

 

 

 

 NAT table

 

사설 ip (local)

 

공인 ip (global)

10.10.10.1

 <->

201.100.10.1

10.10.10.2

 <->

201.100.10.2

10.10.10.3

 <->

201.100.10.3

 

[출처] L3 switch, SVI|작성자 dhaudry88

2016/12/06 11:44 2016/12/06 11:44
http://zosel.net/?/trackback/277
from.promo basket nike  2016/12/15 08:52
Apres un, Dior homme pas cher et T de Yohji Yamamoto est egalement apparu sur scene avec des bouchons laterales.
from.mackage outlet  2016/12/16 11:43
::: ZOSEL ::: :: CISCO L3 NAT 구성
from.外賣茶  2017/02/20 05:05
http://www.eagle-wings.ch/zbn55w/5jafyr.php?pyslsbuh.html
from.е¤–иіЈиЊ¶  2017/02/20 05:18
http://assery.com/-a8-az/pfbhxu.php?sarogpt.html
from.Fitflop Flower Sandals  2018/07/08 12:43
Magnificent goods from you, man. I've understand your stuff previous to and you are just too excellent. I really like what you've acquired here, certainly like what you're stating and the way in which you say it. You make it entertaining and you still ...
ZOSEL:Too much is as bad as too little...!! 자공(子貢)이 공자에게 "사(師:子張의 이름)와 상(商:子夏의 이름)은 어느 쪽이 어집니까?" 하고 묻자, 공자는 "사는 지나치고 상은 미치지 못한다"고 대답하였다. "그럼 사가 낫단 말씀입니까?" 하고 반문하자, 공자는 "지나친 것은 미치지 못한 것과 같다(過猶不及)"고 말하였다.
Too much is as bad as too little...!! 자공(子貢)이 공자에게 "사(師:子張의 이름)와 상(商:子夏의 이름)은 어느 쪽이 어집니까?" 하고 묻자, 공자는 "사는 지나치고 상은 미치지 못한다"고 대답하였다. "그럼 사가 낫단 말씀입니까?" 하고 반문하자, 공자는 "지나친 것은 미치지 못한 것과 같다(過猶不及)"고 말하였다.
전체 (209)
리눅스시스템 (92)
윈도우시스템 (16)
프로그램 (7)
네트워크시스템 (7)
최근관심 (1)
«   2018/10   »
  1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31      
  1. Ugg Sito  2015
    Ugg Sito
  2. Ugg Online  2015
    Ugg Online
  3. Ugg Boots Outlet Italia  2015
    Ugg Boots Outlet Italia
  1. 2018/02 (1)
  2. 2017/03 (2)
  3. 2016/12 (2)