'2013/03/08'에 해당되는 글 1건

  1. [2013/03/08] centos 5.3 이상 json install

centos 5.3 이상 json install

[리눅스시스템/보안]
centos 5.3 이상 json install

복사http://ninja099.blog.me/60176482911

전용뷰어 보기

php 함수인 json_decode, json_encode 등을 사용하기 위해서는 php 5.2 이상이어야 하며, phpinfo()를 통해 --disable-json이 설정되어 있지 않아야 한다.

하지만 필자의 시스템(CentOs 5.8)에서 --disable-json이 되어 있기에 이를 활성화할 필요가 있었다.

이는 아래와 같이 해결하였다.

# yum install php-devel
# yum install php-pear
# yum install gcc
# pear install pecl/json

# cd /etc/php.d
# echo "extension=json.so" > json.ini
# service httpd restart

2013/03/08 17:22 2013/03/08 17:22